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Installation on Linux: Ubuntu
Horus is installed on Linux using the apt-get command. Enter these keys to do this using the 
console. Administrator permissions are required.

sudo add-apt-repository ppa:bqopensource/opencv
sudo add-apt-repository ppa:bqopensource/horus

Then update the system packets by entering these commands into the console:

sudo apt-get update
sudo apt-get dist-upgrade

Once the update has finished, enter the following command to install the program:

sudo apt-get install horus

If you do not have permission to access the serial port, you will need to execute the following 
from console:

sudo usermod -a -G dialout $USER

Lastly, you will need to reboot the system so that the changes are applied correctly. To uninstall 
the program, execute the following from console:

sudo apt-get remove horus

Installing Horus

Installing Horus1 
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Installation on Windows
Horus is installed on Windows by executing the “.exe” file that you can find under the downloads 
section of www.bq.com/gb/products/ciclop.html. Administrator permissions are required.

Follow the steps of the installation wizard below:

Installing Horus
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To communicate with the ZUM BT-328 board, install the FTDI drivers. You can also install them 
for Arduino Uno.

Installing Horus
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Once the wizard has finished, the application will be correctly installed.

Installing Horus
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Camera drivers
If the camera is not detected after you have installed Horus, you will need to install the camera 
drivers.

To do this, download the driver installation software from the manufacturer’s website:  
http://support.logitech.com/en_us/product/hd-webcam-c270

Select your operating system and then click on Download.

Once you have executed the driver installation file, follow the instructions as shown in the images 
below:

Installing Horus
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You only need to install the Logitech Webcam Drivers, so make sure you untick the Logitech 
Webcam Software option.

Installing Horus
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It is advisable to reboot everything after installing the camera drivers and then reinstall Horus 
so that it detects the camera correctly.

Installing Horus
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Welcome screen
This screen appears every time the program is launched or when you click on Help > Welcome 
in the main window.

It is divided into two columns: actions for scanning a new model (New) are listed on the left 
and files for recently scanned models are listed on the right. Click on the desired file to access a 
recently scanned model (Open recent file).

There is also a selection box which allows you to disable this window if you don’t want it to 
appear every time you launch the program (Don’t show this dialog box). This option is unticked 
by default.

Main window
The main window consists of a menu, a task bar and a drop-down menu. The menu contains these 
sub-menus: File, Edit, View and Help.

The task bar icons will vary according to the workbench selected.

Running Horus for the first time2
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Drop-down menu
You can choose from three workbenches in the drop-down menu.

·  Control workbench: enables the scanner components to be controlled separately (Camera, 
Laser, LDR and Motor).

·  Calibration workbench: allows the calibration processes to be carried out which determine 
the fundamental parameters of the scanner.

·  Scanning workbench: enables the scanning to be carried out and the scan parameters to 
be edited.

Menu

File
The File menu enables you to:

·  Run the wizard.

·  Load, Save and Delete models.

·  Open, Save and Reset profiles. A profile is a file with a “.ini” extension, which contains all the 
parameters that the program uses.

In the Control and Calibration workbenches, the actions on models are not available. A model is 
a 3D object. It could be a point cloud (.PLY) or a mesh of triangles (.STL).

Running Horus for the first time
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Edit
From the Edit menu you can access Preferences.

Preferences
The system preferences are:

·  Connection parameters: Serial name, Baud rate and Camera 
ID. If several controller boards or cameras are connected, 
various elements will appear on the list. If no options appear, it 
means that the computer was unable to identify the board or 
the camera. The values selected will be stored in the profile.

·  Upload firmware: enables the firmware to be uploaded to 
the controller. Select the corresponding board (Arduino Uno 
or BT ATmega328) and the Clear EEPROM option if you want 
to delete the data from the internal memory. Finally, click on 
Upload Firmware.

·  Language: allows the language to be selected from the drop-
down menu. It is currently available in English and Spanish.

View
The View menu displays or hides the graphic elements of the different workbenches:

·  Panel: displays the adjustable options and settings. If you move the cursor over some 
options and settings a brief description of them will appear.

·  Video: displays the video captured by the camera.

·  Scene: interactive 3D viewfinder, displays the scanned model in three dimensions.

The program 
configuration data
is stored on
the EEPROM 
memory. Clearing the 
EEPROM memory 
will restore the default 
configuration.

Running Horus for the first time
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Help
This menu provides Information on the application and access to the Welcome screen (Welcome).

Running Horus for the first time
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There are two ways of opening the wizard:

1. From the Welcome screen

It can also be accessed via the Help > Welcome tab.

2. From the File menu

Connection
This screen will appear when the wizard is launched.

Launching the wizard3
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Hit the Connect button. If everything is connected and configured correctly, the video will appear 
in the box on the right.

Next you will have the option to edit preferences. The following settings window will appear:

Here you can adjust the Luminosity type and the Pattern distance.

The pattern distance, which is measured vertically to the base in mm, from the top of the square 
on the bottom left part of the pattern, to the rotating platform of the scanner (as indicated by 
the X in the previous image). It should be as accurate as possible.

Launching the wizard
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The luminosity selected for the wizard should be adequate for detecting the pattern correctly. 
The most suitable luminosity type will enable the pattern to be detected when the platform is 
rotating with the largest angle. To achieve this, return to the previous screen before entering the 
pattern distance, position the pattern as shown in the image and manually rotate the platform 
anti-clockwise. The luminosity type which enables the largest angle to be detected is adequate 
for the calibration. It is advisable to use the luminosity type that makes the image capture clearly 
visible, without being very light.

Then click on Auto check.

If you are configuring the scanner for the first time or you have reset the profile, the following 
window will appear advising you to manually adjust the lasers into a vertical position. This 
adjustment does not have to be 100% accurate as the lasers will be calibrated later by the 
software.

If you click on Yes, the two lasers will light up. Using a smooth surface (such as the calibration 
pattern) to assist you, position the lasers so that they both project a vertical line. Use the screws 
attached to the structure to adjust them.

It is very important to 
position the pattern 
as shown in the image, 
making sure that the 
curve of the pattern 
coincides with the 
curve of the rotating 
platform.

Launching the wizard
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Potential error messages
Wrong Camera: the program detects more than one camera and has selected the wrong one by 
default. Click on OK in the error message window and a preferences menu will appear enabling 
you to select the Camera ID of the scanner.

Board Not Connected: the controller board is not connected correctly to the computer or its 
ID has not been configured properly. Press the OK button and a preferences menu will appear 
enabling you to select the correct board. If nothing appears in the drop-down menu, check that 
the controller board is connected to the computer correctly and check the serial name access.

When the “All OK. Please press Next to continue” message appears, you can click through to the 
next step.

The first step is the calibration of the triangulation lasers, followed by the calibration of the 
platform extrinsics.

Launching the wizard
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Auto check error, please try again: an error may occur on calibration due to selecting the wrong 
luminosity or positioning the pattern incorrectly.  Make sure that the pattern has been detected 
and is in the correct position, then calibrate it again.

Calibration
The lasers of the scanner are calibrated during this step. The calibration pattern should have 
been put in place as shown in the diagram at the previous step. If not, place it manually into this 
position and then click on Calibrate.

Launching the wizard
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If you have not yet entered the pattern distance value, or you have reset the profile, it will appear 
in this pop-up window:

Enter the pattern distance. The image shows the pattern distance as distance X, which is 
measured in millimetres. 

Click on Calibrate to start the process.

Launching the wizard
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Scanning
The last step of the setup wizard is to select the scanning preferences. You will see the following 
options:

·  Resolution: you can select High resolution, Medium resolution or Low resolution. The higher 
the resolution, the longer the scanning time will be.

·  Laser: you can select the Left laser, the Right laser or you can use Both. The scanning time 
will be longer if you use both lasers, but twice as many points will be scanned. Using both 
lasers is recommended as the scanning time will not be twice as long as with one laser under 
the same conditions. 

·  Scan type: you can select Simple or Texture scan. The simple scan uses one image per cycle 
to generate the point cloud and it does not capture the colour of the object. The texture 
scan uses two images to capture the laser and it also generates the point cloud using the 
actual colours of the object.

Launching the wizard
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Once you have finished adjusting the scanning preferences, click on Next and the scanner is now 
ready to start working!

Launching the wizard



USER MANUAL ENGLISH

23

This workbench allows the scanner components to be controlled separately (camera, lasers, 
motor and LDR).

It includes:

·  A task bar on the upper left for connecting and disconnecting the scanner.

·  A control panel containing all the settings.

·  A viewfinder for the camera video.

To connect to the scanner, simply click on Connect. If a problem occurs, such as a device not 
being connected, the Preferences window will open enabling you to select the correct device or 
to update the firmware, etc.

Once the connection to the scanner has been established, the Control panel will be enabled.

Camera control
Under the camera control section you can adjust the following settings:

· Brightness: the luminosity of the image.

· Contrast: the relative difference in intensity.

· Saturation: the colour intensity of the image.

· Exposure: the aperture time of the lens in milliseconds. 

· Frame rate: the images captured per second.

· Resolution: the size of the image. Always in a ratio of 4:3.

· Distortion: corrects the lens distortion according to the calibration.

Control workbench4

Control workbench

Any changes made in 
this workbench will 
not affect the other 
workbenches.
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Laser control
Under this section, the left and right lasers can be enabled or disabled. The verticality can also 
be adjusted using the pattern. The light beam projected by the lasers does not have to be totally 
vertical as the software will automatically calibrate the lasers later, although it is recommendable.

LDR value
An LDR (Light-Dependent Resistor) o photoresistor is a light intensity sensor. If an LDR is 
connected to the controller board, click on the corresponding button (LDR 0 or LDR 1) and the 
sensor value will appear in the dialogue box. The range of this sensor is between 0 and 1023, 
with 0 producing a very low light intensity and 1023 producing a very high intensity.

Control workbench

We aim to include this 
type of sensor in later 
versions so that some  
of the camera settings 
can be automatically 
adjusted according 
to the LDR values 
given, making the 
user experience even 
simpler.
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Motor control
Under this section you can Enable / Disable the motors. You can also move them, with options 
to adjust the angle of the step, the feed rate and the angle acceleration in degrees, degrees per 
second and per second squared, respectively.

Gcode control
The Gcode commands appear under this section, which are the commands used in order to 
communicate with the controller board. In concrete terms, the following list of commands is 
available, with “v” being a numerical value:

· To adjust the motor speed: G1 Fv

· To move the motor v degrees: G1 Xv

· To enable the motor: M17

· To disable the motor: M18

· To enable the laser: M71 Tv

· To disable the laser: M70 Tv

· $$ access to internal settings

The motor consumes 
almost the same 
amount of electricity 
when simply enabled 
as  when it is moving. 
Bear in mind that 
if the motor is left 
enabled for a long 
time, both the motor 
and the control driver 
will heat up.

Control workbench
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The Calibration workbench enables the settings of the scanner components to be adjusted:

·  Camera settings: to adjust the images captured by the camera.

·  Pattern settings: to adjust the calibration pattern settings.

·  Laser settings: to enable / disable the lasers and also to adjust the laser detection settings.

This workbench also enables you to carry out processes that determine the main calibration 
settings:

·  Camera intrinsics: calibration of the camera sensor and the lens.

·  Laser triangulation: calibration of the camera and the laser modules.

·  Platform extrinsics: calibration of the camera and the rotating platform. 

This workbench includes:

·  A task bar on the upper left for connecting and disconnecting the scanner.

·  A panel containing all the calibration settings.

·  A viewfinder for the camera video or the different sections of the calibration processes.

Remember that due to the fact that the product is set up manually, the distances and positions 
of the elements of each scanner will be different. These specific settings are determined by 
carrying out calibration processes so that the results obtained from each scanning are the same, 
independently of the device.

The adjustment headings (Camera settings, Pattern settings and Laser settings) include:

·  Name of heading.

·  The Undo button to undo the last change made.

·  The Reset button to restore the default settings.

The auto-calibration settings (Camera intrinsics, Laser triangulation and Platform extrinsics) 
include:

·  Name of calibration.

·  Calibration settings.

·  The Edit button to edit the values manually.

·  The Default button to restore the default settings.

·  The Start button to launch the relevant calibration process.

Calibration workbench5

Calibration workbench
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Camera settings
Calibration of the scanner consists of different stages, all of which use the same calibration 
pattern.

The calibration settings are the settings which can be adjusted on the camera: Brightness, 
Contrast, Saturation, Exposure, Frame rate, Resolution and Distortion.

If the pattern has been correctly detected, it will appear with the corners highlighted by coloured 
dots and joined by lines (as shown in the diagram). If no lines appear, it has not been detected 
properly and you will need to adjust the camera settings until it is detected.

Pattern settings
The calibration pattern settings can be configured in this section.

The pattern comes with black and white squares measuring 13 mm on each side as standard. 
The value of the rows and columns of the pattern does not correspond to the number of rows 
and columns of black and white squares on the existing pattern. The settings to be entered are 
the columns and rows formed by the corners of the internal squares. In the image below, the 
outlined columns and rows are shown in different colours.

Calibration workbench

Configuring the 
camera for calibration 
is done to ensure that 
the pattern is detected 
correctly.

In order to calibrate 
correctly, it is important 
to ensure that the 
pattern is properly 
detected in the light 
conditions of the 
scene and in different 
positions.
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The pattern distance refers to the distance, measured in mm, from the top of the square on the 
bottom left part of the pattern, to the rotating platform of the scanner (as indicated by the X in 
the image below).

All of these settings can be modified if you use a different pattern.

Laser settings
The buttons to enable the Left and Right lasers can be found in this section. You can adjust the 
verticality of the lasers using the pattern. The lasers do not have to be totally vertical to the 
camera, as the inclination will be automatically correction during calibration, but it is advisable 
to make them as perpendicular as possible.

Calibration workbench

If you change any of 
the  pattern values, 
you must calibrate the  
laser triangulation and 
the platform extrinsics 
again, or otherwise use 
the wizard.
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Camera intrinsics (calibration optional)
The internal camera settings are obtained from this calibration process. These include:

· Focal lengths (horizontal and vertical)

· Optical centre (horizontal and vertical)

· Lens distortion

This calibration depends on the resolution of the camera. In general, the higher the resolution, 
the greater the settings obtained from this calibration process.

This calibration process is optional, given that the cameras supplied are all practically identical 
and the experimental values are very close to the theoretical values. However, this option is 
reserved for advanced users.

Calibration workbench
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The first window will proceed to capture the 12 valid patterns in different positions and 
inclinations. To do this, put the pattern in place and press the Space key.

If you do not capture the pattern correctly, the image will appear in red and you will have to 
repeat the process, as shown in the last image.

Once you have obtained the images, you can proceed to calibrate automatically. The results 
of the calibration process will be displayed numerically and with a 3D graph, which shows 
the coordinate system of the camera and each coordinate system of the patterns captured 
previously.

At this point, you will have the option to accept or reject the results obtained from the calibration 
process.

Laser triangulation
During this calibration process, the inclination and distance of the intersection between the 
lasers and the central plane of the camera. It is one of the most important calibration processes.

The Start button to launch the calibration process.

Calibration workbench
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Put the pattern in place as shown in the image and press the Calibrate button. You will have the 
results within seconds.

The results are shown on a matrix which defines the inclination of the lasers in pixels and the 
depth of the pattern. The graph also displays the inclination of the lasers towards the camera.

You can use these parameters to determine whether a laser calibration is acceptable or not:

1.  The point spread of the plane in millimetres: the spread of the distance at the plane of the 
points is obtained in order to calculate the plane. If it is 0, this means that all points belong 
to the plane. Values around 0.1 are adequate.

2.  The minimum distance from the original plane, measured in millimetres according to 
the camera coordinate system: the difference between these values should not exceed 
30 units.

As with the previous calibration process, you can accept or reject the results obtained.

Calibration workbench
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Platform extrinsics
The homogeneous transformation matrix of the rotating disc in relation to the camera is 
obtained from the extrinsic calibration. In other words, the position and rotation of the disc. 
This calibration process is also very essential, along with the laser triangulation.

Put the pattern in place as shown in the diagram and then click on Calibrate.

Then disc will then move in small intervals until it has completed 180 degrees. The process will 
take around 20 seconds.

The results of the calibration process will be displayed on the next screen. A graph will also 
appear displaying the samples that have been captured, as well as the rotation centre of the disc.

As with the previous calibration processes, you can accept or reject the results obtained.

In the two essential calibration processes; the laser triangulation and the disc transformation, 
the intrinsic calibration values are used. If you are calibrating the camera, it is convenient to carry 
out the other two processes in order to generate coherent results.

Calibration workbench
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This workbench includes:

·  A task bar on the upper left for connecting and disconnecting the scanner, and starting, 
stopping or pausing the scanning process.

·  A control panel displaying the scan parameters and options.

·  A viewfinder for the camera video.

·  A 3D viewfinder which displays the point cloud in real time as it is generated from the 
scanning process (Scene).

The Panel, Video and Scene windows can be enabled or disabled by going to View > Scanning.

Video display window
This window shows the video captured by the camera in real time. It is possible that the scanning 
process will not be displayed in real time due to the image processing.

In this window you will see a button with the image of an eye. If you click on it during the scanning 
process, a drop-down menu will appear containing different viewing options.

Scanning workbench6

Scanning workbench
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·  Laser: shows the images captured by the camera with the laser.

·  Grey: shows the part of the model illuminated by the laser before being processed.

·  Line: final line of points, resulting from the image processing obtained with the camera.

Scanning workbench
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·  Colour: shows the images captured by the camera, excluding the laser.

Control panel
The scanning process has its own settings and adjustments for the camera, the lasers, the motor 
and the image processing algorithms and the point cloud.

The settings can be adjusted manually using this panel and they are divided into the following 
sections:

Scan parameters
The following settings can be modified in this section:

·  Scan type: select from Simple scan or Texture scan. The simple scan uses one image per cycle 
to generate the point cloud and it does not capture the colour of the object. The texture scan 
uses two images to capture the laser and it also generates the point cloud using the actual 
colours of the object.

·  Use laser: you can select the Left laser, the Right laser or Both. The scanning time will be 
longer if you use both lasers, but twice as many points will be scanned. Using both lasers is 
recommended as the scanning time will not twice as long as with one laser under the same 
conditions.

·  Fast scan: an experimental option which is only available for the Linux version. It practically 
reduces the scanning time by half, without affecting the resolution. Being an experimental 
option, some errors might occur during the scanning process.

Scanning workbench
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Rotating platform
In this section you can adjust the Step degrees moved by the platform, as well as the Feed rate 
and Acceleration.

As small step, for example of 0.45º, generates greater radial point density than a larger step (5º). 
Due to the electronics, the steps must be multiples of 0.1125º. A low feed rate and acceleration 
are recommended in order to prevent oscillations caused by inertia from appearing.

Image acquisition
The settings that affect the image acquisition can be adjusted in this section. These include:

·  Brightness: the luminosity of the image.

·  Contrast: the relative difference in intensity.

·  Saturation: the colour intensity of the image.

Scanning workbench
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·  Exposure: the exposure of the laser is the time, measured in milliseconds, which the camera 
lens remains open in order to capture the light beam projected by the laser. 

·  Resolution: the size of the image. Always with a ratio of 4:3. It is very important that this 
value matches the resolution value entered during calibration, otherwise the results will 
not be coherent. You should always use the maximum resolution.

·  Distortion: this settings allows the lens distortion to be corrected.

Scanning workbench
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Image segmentation
Here you can modify the segmentation for the images captured by the camera. Bear in mind that 
there are different settings for Simple scan and Texture scan.

For the Simple scan you can have the option to use Threshold. If you enable it, you can change 
the value using the adjustment bar.

For the Texture scan, in addition to use Threshold, you also have the option to use Open. This 
option will apply the Open algorithm which, together with use Threshold, helps to reduce the 
noise during scanning. The higher the Open value, the lesser the noise during scanning and the 
lesser the detail on the final 3D model.

Point cloud generation
The settings that affect how the point cloud is generated can be adjusted in this section.

Scanning workbench
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·  View ROI: this element can be enabled or disabled. It displays the edges of the cylinder, 
which is the region of interest. By adjusting the region of interest of the object to be scanned 
and by changing the Diameter and Height, the chances of scanning undesired elements are 
minimised and noise is reduced. It also displays the centre of the rotating platform, which 
is useful for centring the object.

·  Choose point cloud colour: this option allows you to select the colour of the point cloud for 
the Simple scan. The option is not available if you are using the Texture scan.

To verify that the ROI is centred on the platform, adjust the diameter to 200. If  the base 
of the cylinder (blue) more or less coincides with the edges of the platform surface, the ROI 
can be considered to be centred.
The ROI is off-centre if the cylinder that represents it is above or below the platform. This 
imbalance may be due to poor calibration of the platform and/or the pattern.  To correctly 
locate the region of interest, check the pattern settings and calibrate the triangulation 
lasers and platform extrinsics, or alternatively, use the wizard.
The image  on the left shows the ROI off-centre because it is above the platform.

Scanning workbench
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3D viewfinder scene
The viewfinder scene shows the point cloud in real time as it is generated from the scanning 
process. It also enables viewing of complete point clouds and 3D models (.stl).

Shortcuts
These are the shortcuts for the Horus work environment:

Action Shortcut 1 Shortcut 2

Default views Home / PgUp / PgDn / End

Rotate Left click Shift + Up/Down

Rotate horizontally Up / Down

Rotate vertically Left / Right

Vertical shift Ctrl + Mouse wheel Ctrl + Up / Down

Reset vertical shift Double left click

Translation Shift + Left click

Zoom Mouse wheel Shift + Up / Down

Delete object Right click  + Delete object

Quit program Ctrl + Q

Scanning workbench
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