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FlexiPanel 

FlexiPanel Designer
User Interface design tool for FlexiPanel User Interface Servers

  

Summary 
FlexiPanel is a generic technology for allowing one 
device (the FlexiPanel Server) to create a user 
interface on another device (the FlexiPanel Client).  
It provides a wireless universal remote control and 
monitoring facility for computer software and 
electronic products, eliminating the need for user 
interface components.  

The FlexiPanel Designer is software to aid in the 
design of FlexiPanel user interfaces.  The user 
interface may be specified and tested from within 
the design tool and then exported to a specific 
FlexiPanel Server.  The controls that can be 
displayed are: 

Blob Matrix 
Button Message 

Date-Time Number 
Files Password 

Image Section 
Latch Text 
List  

 

New for version 3.0 

FlexiPanel Designer 3.0 includes the following 
enhancements.  Items marked * may only take 
effect on version 3.0 clients. 

• Support for Toothpick platforms including 
Toothpick Slave, DARC-II, Stamp Edition 
and MPLAB 

• Multiple dialog user interfaces 

• Image control which can generate a 
message when clicked upon* 

• Message controls can send replies, e.g. Yes 
/ No or OK / Cancel* 

• Disabled controls* 

• Centered / right justified text controls* 

• Progress bar and slider controls* 

• Minimum & maximum char axis values* 

• Partial update message for faster chart 
updates* 

• Inline charts* 

• Save chart data to file* 

 

Computer or 
other product 

Remote device, 
e.g. Pocket PC 

FlexiPanel 
Client 

Software 

Display 

Bluetooth FlexiPanel
Server 

User Interface 
resources  

FlexiPanel Designer manages the user interface 
resources stored on the FlexiPanel Server 

What does Designer 3.0 do?  

FlexiPanel Clients display user interfaces on 
behalf of FlexiPanel Servers. 
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A Quick Visual Tour 
 

  

FlexiPanel Server Properties View  

 

 

 

  

Target Properties View  

Click on a control to 
modify its properties 

Add a control from 
the list in the toolbar 

Modify Server 
features in the list 

Hints about 
selected list item 

Change view

Click on a control to 
modify its properties 

Add a control from 
the list in the toolbar 

Modify Target 
features in the list 

Hints about 
selected list item 

Change view 
Change target
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Control Properties View  

 

 

  

Pocket PC Properties View  

 

Click on a control to 
modify its properties 

Add a control from 
the list in the toolbar 

Modify Control 
features in the list 

Hints about 
selected list item 

Change view 

Select, drag and 
size controls 

Unplaced controls 
appear here 

Modify selected control 
properties in the list 

Hints about 
selected list item 

Change view 

Selected control 
in darker blue 

Change the dialog being 
displayed with the Show 

Dialog property 



Page 5 29-Jan-07 Designer rev 2 © FlexiPanel Ltd Patents apply and/or pending  www.FlexiPanel.com 

 

Windows Properties View  

 

 

Smartphone Properties View  

 

The Java phone client is not customizable and so it does not have a properties view. 

Click on a control to 
modify its properties 

Modify selected control 
properties in the list 

Hints about 
selected list item 

Change view Unplaced controls 
appear here 

Select a control to 
set its properties 

Modify control 
properties in the list 

Hints about 
selected list item 

Change view 

Selected control in 
darker blue 

Change the dialog being 
displayed with the Show 

Dialog property 
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Overview  

Concepts 

FlexiPanel Clients connect to FlexiPanel Servers.  
A client may connect to a server at any time.  
Once the connection is made, the server tells the 
client to display the desired user interface on its 
display.   

The server may modify the contents and 
appearance of the controls at any time, and even 
replace the entire ‘dialog’ with another.  

If the client modifies a control, for example 
pressing a button, it sends a message to the 
FlexiPanel Server. 

Either the server or the client may choose to 
disconnect at any time.  Additionally, the link may 
be dropped if the devices go out of range of each 
other.  The state of the controls is retained by the 
server so that if the client reconnects, or another 
client connects, the user interface will be in the 
same state as it was when it was last modified. 

Devices incorporating FlexiPanel Servers must be 
designed taking into account the possibility of a 
dropped connection.  Specifically, no action should 
be taken which relies on a client’s ability to 
maintain a connection.  If FlexiPanel is used to 
operate machinery, for example, the application 
should provide a failsafe mode should the 
connection be dropped. 

FlexiPanel Controls 

Thirteen control types are provided by FlexiPanel.  
These include controls familiar to Windows users 
and others that are particularly appropriate for 
FlexiPanel technology.  Not all controls are 
supported by all targets.  In particular, support for  
Blob and Files controls is platform dependent. 

FlexiPanel Clients are required to provide all the 
requested controls in some form or other.  Since 
the user interface may vary from one FlexiPanel 
Client to another, the appearance is not 
guaranteed.   

If the developer expects a device to be used in 
conjunction with a specific type of FlexiPanel 
Client (e.g. Pocket PC), it may specify those Client 
Settings in more detail; however, the user interface 
will still work on any FlexiPanel Client. 

Generic Control Properties 

All controls possess certain generic properties.  
These are set when the control is first specified 
and they may be modified at any time. 

• All controls have a title, although the client 
may not necessarily display this. 

• Some controls are either modifiable or non-
modifiable.  If a control is non-modifiable, the 
server may change its value but the client may 
not. 

• A control may be invisible, in which case it is 
not accessible to the user.  

• A control may request to be brought to the 
user’s attention.  If more controls are specified 
than can appear on the screen at once, the 
FlexiPanel Client will implement some kind of 
scrolling or paging mechanism.  Such a 
request will ensure that the control is brought 
into view. 

• Right-to-left text style may be requested, 
although it is not guaranteed that the client can 
fulfill this request.  

• Controls may be grouped together.  If possible, 
the client will use this information to lay out the 
controls in a logical manner.  

• Controls have a color. If possible, the client will 
display the control in this color. 

Blob Control 

The blob (Binary Large Object) control allows 
client and server to pass binary objects to each 
other.  It is intended primarily for future expansion 
and customization.  Due to the limitations of some 
client devices, a client is not obliged to support all 
features associated with this control; some clients 
may simply ignore it.   

In this release of FlexiPanel, the only use of the 
blob object is to pass the name of a URL (i.e. web 
page address) to the client.   

Button Control 

A button control registers when a button is pressed. 
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DateTime Control 

A DateTime control stores a DateTime value, i.e. 
second, minute, hour, date, day-of-week, month 
and year. 

Files Control 

The files control allows the server to pass files to 
the client.  It is only optionally supported by clients 
and servers. 

A predefined use of the file object is to pass web 
pages to a client. Provided the client has a web 
browser, it can display the web page, even if it is 
not connected to the internet.  This would allow the 
server to upload, for example, an entire instruction 
manual to the client.  In theory, this functionality 
could be provided in the library but it is very port-
specific and will only be provided on request. 

Latch Control 

A latch control stores a binary (on/off) value.  
Latches may be arranged in groups so that when 
one latch is turned on the others are turned off. 

List Control 

A list control allows one item to be selected from a 
list. 

Matrix Control 

A matrix control stores an array of numbers.  
These might be displayed as a table or a chart.  In 
this release of FlexiPanel, the values are not 
modifiable by the client. 

Message Control 

A message control displays a message on request.  
From version 3.0, the client can display a 
combination of buttons such as Yes and No or OK 
and Cancel and it will report back to the server 
which button was pressed. 

Number Control 

A number control stores a numeric value.  It is 
essentially a signed four-byte integer, but its 
decimal place may be shifted left or right in order 
to represent any floating-point value. 

Password Control 

A password control stores a password and has an 
open and closed state.  In the closed state, the 

user must enter the password to set it to the open 
state. 

In the open state, the password control may be 
returned to the closed state at any time. 

It is possible to specify that a password may be 
modified by the user once the control is in the 
open state.  A master password may also be 
provided. 

Passwords are limited to 16 Unicode characters or 
33 ASCII characters.  Some remote devices can 
only enter the digits 0-9 in a password-style text 
control. 

Section Control 

A section control acts like a pop-up menu.  
Controls enclosed within a section control are only 
visible when the section control is opened. 

Controls enclosed inside a closed section control 
are not transmitted to the client, thus minimizing 
communication time. 

Text Control 

The text control contains a text string.  It will have 
a fixed maximum length, specified when the 
control is created. 

A text control may have password style, in which 
case the text entered in the control is not readable 
by the user. 

It is possible to specify that text control is intended 
to be the title of the following control or group of 
controls. If possible, the client will use this 
information in laying out the controls in a logical 
manner.  Some remote devices can only enter the 
digits 0-9 in a password control. 

Requirements 

To simulate user interfaces, the computer running 
FlexiPanel Designer needs to be Bluetooth 
equipped.  A FlexiPanel Client device will also be 
required.  This can be a Bluetooth-equipped 
Pocket PC.  The software required can be 
downloaded free from www.FlexiPanel.com.  The 
client cannot be the same device as the server.  
FlexiPanel Designer requires Windows 2000 / 
Windows XP. 
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FlexiPanel Protocol 3.0 

The communication standard used by FlexiPanel 
Designer 3.0 in order to communicate with clients 
is FlexiPanel Protocol 3.0.  This is backwardly 
compatible with FlexiPanel Protocol 2.x except 
where specifically noted.   

FlexiPanel Protocol 1.0 is an infrared protocol and 
so no attempt is made to be backward compatible 
with it.  Every effort will be made to keep future 
Bluetooth FlexiPanel Protocols backwardly 
compatible with earlier versions. 

Third Party Developers 

The document FlexiPanel Protocol 3.0 provides 
detailed information about the protocol for third 
parties who wish to develop their own servers and 
clients 

Development of third party clients is more or less 
unrestricted.  Developers of third party server 
products will need to pay a royalty to FlexiPanel 
Ltd.   
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Software Operation 
FlexiPanel Designer manages the list of controls 
that are to be displayed.  Various views are 
provided to control different aspects of the 

controls, such as how they are managed, how they 
appear on specific client software, etc.  Once a 
user interface has been designed it may be 
simulated using a Bluetooth-equipped PC, and 
then programmed into a specific target such as 
FlexiPanel BASIC Stamp edition or DARC module. 

  
Menu Item  Tool Function 
File > New Creates a new, blank user interface design. 
File > Open  Opens a previously saved user interface design.  
File > Save Saves a user interface design.  
File > Save As…  Saves a user interface design under a new file name.  
File > Recent Files  Opens recently saved user interface designs. 
File > Exit  Closes the FlexiPanel Designer application. 
Edit > Up Moves a control up the list of controls in the Control Properties view. 
Edit > Down  Moves a control down the list of controls in the Control Properties 

view. 
Edit > Insert Blob  Inserts a blob control. 
Edit > Insert Button  Inserts a button control. 
Edit > Insert DateTime  Inserts a date-time control. 
Edit > Insert Files  Inserts a files control. 
Edit > Insert Image  Inserts an image control. 
Edit > Insert Latch  Inserts a latch control. 
Edit > Insert List  Inserts a list control. 
Edit > Insert Matrix  Inserts a matrix control. 
Edit > Insert Message  Inserts a message control. 
Edit > Insert Number  Inserts a number control. 
Edit > Insert Password  Inserts a password control. 
Edit > Insert Section  Inserts a section control. 
Edit > Insert Text  Inserts a text control. 
Edit > Insert Copy  Inserts a copy of the currently selected control. 
Edit > Delete  Deletes the currently selected control. 
View > Toolbar  Displays / hides the toolbar. 
View > Status Bar  Displays / hides the status bar. 
View > FlexiPanel Properties  Displays general FlexiPanel Server properties in the properties list on 

the right side of the screen. 
View > Control Properties Displays the control properties in a list. 
View > {Target} Properties Displays the properties relating to how the user interface is simulated.  

(Only shown when the Simulation target is selected.) 
View > Pocket PC Properties  Displays the properties relating to how the user interface appears on a 

Pocket PC. 
View > Windows PC Properties  Displays the properties relating to how the user interface appears on a 

Windows PC. 
View > Smartphone Properties  Displays the properties relating to how the user interface appears on a 

SmartPhone. 
Target > Simulation  Selects a Simulation as the target. 
Target > Serial Adapter  Selects a FlexiPanel Serial Adapter module as the target. 
Target > BASIC Stamp Edition  Selects a FlexiPanel BASIC Stamp Edition module as the target. 
Target > Toothpick DARC-II  Selects a Toothpick DARC-II module as the target. 
Target > Toothpick Slave  Selects a Toothpick Slave module as the target. 
Target > Toothpick Stamp 
Edition  

Selects a Toothpick Stamp Edition module as the target. 
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Menu Item  Tool Function 
Target > Toothpick MPLAB  Selects a Toothpick as the target using the MPLAB development 

environment. 
Target > {Program target}… Sends the user interface information to the target.  In the case of the 

simulation target, a FlexiPanel server is simulated on the PC. 
Help > Troubleshooting 
Guide…  

Launches a web browser to show the latest Bluetooth troubleshooting 
information  

Help > DateTime Format 
Help…  

Displays a table of the codes used in date-time format strings. 

Help > About Designer...  Shows the version of FlexiPanel Designer in use. 
 

FlexiPanel Server Properties 

Default dialog on disconnect – (Toothpick only)  
When a client disconnects, the server switches the 
displayed dialog back to the default, which starts 
with the first control in the control list. 

Device name – The name of the device.  This will 
appear when a client views a list of FlexiPanel 
devices in range and also in the title bar once the 
client has connected.  In some clients, it is also 
used as a registry key to store client/server 
specific preferences.  Consequently, the name 
should be unique to the device.  The name will be 
generated at random initially; set it to your desired 
product name.   

Force Layout – Specifies that the client should 
always adopt the layout recommendations 
provided by the server.  Usually, the client will 
request the layout only when it first encounters the 
server.  This allows the user to re-arrange the 
controls as desired.  During development, it is 
preferable to request the layout every time.  The 
Force Layout option achieves this by appending a 
unique number onto the end of the device name.  
This makes the client think it is encountering a new 
server each time.  It is recommended that Force 
Layout is enabled throughout the development 
cycle and then disabled for the final product. 

One Shot – Specifies that the server should 
immediately disconnect from the client after the 
user interface has been sent.  Quick disconnection 
means that many clients may connect in an ad-hoc 
manner without blocking each other’s access too 
frequently.  This feature is for “informational” rather 
than “control” services, since the client will have no 
opportunity to send information back to the server.  
Specifically, there is no point in having any client-
modifiable controls on the user interface. 

Ping Client – Specifies that the server should 
check that the client is still attached. 

Ping Frequency – Specifies how frequently the 
server should check that the client is still attached 
(in seconds). 

Request Acknowledge – (Toothpick only)  
Requests acknowledgement from remote device 
after all to client update messages. 

Unicode – Specifies Unicode text operation.  If 
Unicode text is specified, two bytes are used to 
represent each text character rather than one.  
This allows for all character sets to be represented, 
although is somewhat less memory efficient.  If 
Unicode is not specified, text should be restricted 
to single-byte ASCII text.  Note that selecting 
Unicode does not guarantee that the specified 
characters will appear on the client, since the client 
may not have the relevant character set loaded.  
(For example, don’t expect a Hungarian mobile 
phone to display Chinese characters.) 

Lowest Client Version – Specifies the lowest 
version of the FlexiPanel which can understand 
this server and should be allowed to connect to it.  
Select 2 unless image controls are used or row 
update messages must be sent. 

Control Properties 

The main screen displays all the controls in a list.  
The list displays the control name, type, 
description and ID.  The ID is allocated by 
FlexiPanel Designer and cannot be changed.  The 
description includes, at the end, a summary of the 
memory storage required for this control.  (In 
addition to the storage required for the control, a 
small additional amount of ROM storage will be 
required for other settings.  The amount of the 
additional storage required varies from target to 
target.)  

The Control Properties displayed in the properties 
list on the right of the screen will depend on the 
control selected and also the target device.   
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Multiple Dialogs 

The Toothpick target allows several dialogs to be 
specified.  These are all displayed as one long list 
with odd-numbered dialogs shown with their 
Control Names indented.  To start a new dialog, 
inset a new control and set the New Dialog 
property to yes. 

The section control has ‘sub-controls’ which are 
listed directly below the section control.  These all 
have the text in the Type column indented. To 
create sections with sub controls, insert the section 
control and then its child controls directly below.  
Then go back to the section control and the Sub 
Controls property to the number of controls inside 
the section (including and controls inside sub-
sections). 

All controls 

Color, Color R/G/B – Specifies whether a specific 
color is requested for the control.  A client may or 
may not be able to fulfill this request.  Each 
component (R/G/B) should be in the range 0 to 
255. 

Data From Pin – (Toothpick DARC-II only) 
specifies that the state of the control is set by the 
value of an input pin. 

Data Overlay Control – See Data Storage. 

Data Storage – Specifies how control data is 
stored: 

• RAM data is lost if the server power is lost.  

• ROM data is retained even without power, but 
the memory has a lifetime of around 100,000 
writes.  There are storage issues with the 
Stamp Programmer if the Client modifies a 
control with ROM storage – refer to the 
warning message generated. 

• EE data is retained even without power, but 
the memory has a lifetime of around 100,000 
writes. 

• EXT data requires the appropriate external 
memory to be connected.  External memory 
must be programmed with the correct initial 
values.  The Toothpick MPLAB target allows 
you to create a .hex file with this data and 
you can then use the Wireless Field 
Programming to program it.  Consult the 
Toothpick documentation for more details. 

• Overlay specifies that the data should use 
same memory locations as the control 
specified by Data Overlay Control.  Overlay 
controls have two main uses - for multiple 
references to large data controls (e.g. files, 
images), and multiple language renditions of 
the same control. 

Data To Pin – (Toothpick DARC-II only) specifies 
that the state of the control sets the value of an 
output pin. 

Disabled – Specifies that a control is initially 
disabled.  (Version 3.0 clients only.) 

End Group – Indicates that the control is the last of 
several of controls which logically form a group 
and should appear together in the FlexiPanel’s 
user interface. (Refer to FlexiPanel Client 
documentation as to how this is interpreted, if at 
all.) 

New Dialog – (Toothpick target only) Set to Yes to 
indicate that the control is the first control in a new 
dialog box.  (Ignored if set to yes for the first 
control in the list.) 

Right-to-Left– Requests that text be shown in 
Right-to-Left format (e.g. for Arabic script).  There 
is no guarantee that a FlexiPanel Client will be 
able to comply with the request. 

Start Group – Indicates that the control is the first 
of several of controls which logically form a group 
and should appear together in the FlexiPanel’s 
user interface.  (Refer to FlexiPanel Client 
documentation as to how this is interpreted, if at 
all.) 

Title – Title of the control.  The control title is used 
in three ways: 

• Within FlexiPanel Designer, to refer to the 
control. 

• As the control’s title, if this is displayable 
by the client. 

• By some controls, for example the text in a 
button control. 

Visibility / Visibility password – Specifies that a 
control is only visible when a specific password 
control is unlocked. 

Blob controls 

Currently a Blob control may only be used to send 
a URL (i.e. a web address) to a client device.  
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Some servers do not support this control.  Some 
clients may ignore this control. 

URL – Specifies the web address to seek. 

Button controls 

There are no specific settings for the Button 
control. 

Date-Time controls 

Format string – Specifies how the date / time is 
displayed.  The text is displayed as written, after 
substituting the following: 

%H% Hour, 24 hour format. 
%HH% Hour, 24 hour format, 2 digits always. 
%h% Hour, 12 hour format. 
%hh% Hour, 12 hour format, 2 digits always. 
%m% Minute. 
%mm% Minute, 2 digits always. 
%s% Second. 
%ss% Second, 2 digits always. 
%d% Date. 
%dd% Date, 2 digits always. 
%ddd% Day of week, three characters. 
%dddd% Day of week. 
%M% Month number. 
%MM% Month number, 2 digits always. 
%MMM% Month, three characters. 
%MMMM% Month. 
%yy% Year, 2 digits only. 
%yyyy% Year. 
%t% A for AM, P for PM. 
%tt% AM or PM. 

This substitution table is also shown when Help > 
Date-Time Format Help is selected from the menu. 

Initial … value – The value control assumes at 
start-up. 

Modifiable – Specifies whether any of the elements 
of the Date-Time control are modifiable. 

Modify hour – The hour value specifically is 
modifiable by the client. 

Modify minute – The minute value specifically is 
modifiable by the client. 

Modify second – The second value specifically is 
modifiable by the client. 

Modify date – The date value specifically is 
modifiable by the client. 

Modify weekday – The weekday value specifically 
is modifiable by the client. 

Modify month – The month value specifically is 
modifiable by the client. 

Modify year – The year value specifically is 
modifiable by the client. 

Real time clock – The server should tie this 
control’s value to its real time clock.  (Not all 
servers support this.)  On the Stamp Programmer, 
the real time clock updates the client device only 
every 5 seconds. 

Files controls 

The Files control passes files from the server to 
the client. Some servers do not support this control. 
Some clients may ignore this control. 

Hint – Selecting HTML specifies that the first file 
sent should be opened up in a web browser. 

Files – Compiles the list of files to be sent to the 
client.  Double-click to activate this control.  To 
select multiple files, you will need to hold down the 
Ctrl or Shift keys while clicking on the filenames. 

Latch controls 

Initially on – If selected, the latch is On when 
initialized. 

Radio button – If selected, the latch forms part of a 
radio button group.  In a radio group, turning on 
one latch will turn off all others. 

Radio group – If the user presses a radio button, 
all other latches with the same Radio Group 
number will automatically be turned off.  Pressing 
a radio button more than once has no effect. 

Reset Button – If the user presses a reset radio 
button, all other latches with the same Radio 
Group number will automatically be turned off.  
The reset button itself, however, never appears to 
be in the On state. 

List controls 

List Items – The items to appear in the list, 
separated by semicolons. 

Initial selection – The item selected at start-up 
(zero-based). 
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Matrix controls 

The matrix control stores data as a two-
dimensional array of integers and displays them in 
a table or as a chart.  Large values and non-
integer values are represented by shifting the 
decimal point of the value displayed. 

Cell decimal format – Floating point will show as 
many decimal places as required to display the 
value.  Fixed Point will show the number of 
decimal places specified by Decimal Places.  
Exponent displays the same value in exponential 

format (i.e. 6104×  is represented as 4.000e06).  
Shortest selects the shortest of these formats. 

Cell decimal places – Specifies how many digits 
are shown after the decimal point. 

Cell decimal shift – Specifies how to translate the 
internally stored integer into the value seen by the 
user.  If the integer value is 456, a shift of 0 would 
represent it as 456, a shift of 2 would represent it 
as 45600, a shift of –2 would represent it as 4.56. 

Cell format string – Allows text to be placed before 
and after the numeric value when displayed in a 
table or on the axis.  %% in the format string will 
be replaced by the numeric value.  For example, if 
5.67 was the value and d=%%cm was the format 
string, d=5.67cm would be displayed. 

Cell storage – Specifies how many bytes are used 
to store the integer.  1-byte displays values on the 
range -128 to +127.  2-byte displays values in the 
range -32768 to +32767.  4-byte displays values in 
the range -2147483648 to +2147483647. 

Column titles – The names of the columns, 
separated by semicolons.   

Max rows – The maximum number of rows in the 
matrix.   

X-axis type – The properties associated with each 
row.  Four X-axis types are possible, and the 
remaining properties are enabled depending on 
the X-axis type: 

List  – The rows appear in sequence, with no extra 
information associated with them. 

XY – Each row is associated with a numeric value.  
If shown in a chart, this is where the data is plotted 
relative to the X-axis. 

Row decimal format – Floating point will show as 
many decimal places as required to display the 

row value.  Fixed Point will show the number of 
decimal places specified by Decimal Places.  
Exponent displays the same value in exponential 

format (i.e. 6104×  is represented as 4.000e06).  
Shortest selects the shortest of these formats. 

Row decimal places – Specifies how many digits 
are shown after the decimal point. 

Row decimal shift – Specifies how to translate the 
internally stored integer into the row value seen by 
the user.  If the integer value is 456, a shift of 0 
would represent it as 456, a shift of 2 would 
represent it as 45600, a shift of –2 would represent 
it as 4.56. 

Row format string – Allows text to be placed before 
and after the row value when displayed in a table 
or on the axis.  %% in the format string will be 
replaced by the numeric value.  For example, if 
5.67 was the value and d=%%cm was the format 
string, d=5.67cm would be displayed. 

Row storage – Specifies how many bytes are used 
to store the row value.  1-byte displays values on 
the range -128 to +127.  2-byte displays values in 
the range -32768 to +32767.  4-byte displays 
values in the range -2147483648 to +2147483647. 

Labels  – Each row has a text label. 

Row labels – The text labels of the rows, 
separated by semicolons.   

DateTime  – Each row represents a moment in 
time. 

Row date-time format – Specifies how the row 
value is displayed.  The text is displayed as written, 
after substituting the following: 

%H% Hour, 24 hour format. 
%HH% Hour, 24 hour format, 2 digits always. 
%h% Hour, 12 hour format. 
%hh% Hour, 12 hour format, 2 digits always. 
%m% Minute. 
%mm% Minute, 2 digits always. 
%s% Second. 
%ss% Second, 2 digits always. 
%d% Date. 
%dd% Date, 2 digits always. 
%ddd% Day of week, three characters. 
%dddd% Day of week. 
%M% Month number. 
%MM% Month number, 2 digits always. 
%MMM% Month, three characters. 
%MMMM% Month. 
%yy% Year, 2 digits only. 
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%yyyy% Year. 
%t% A for AM, P for PM. 
%tt% AM or PM. 

This substitution table is also shown when Help > 
Date-Time Format Help is selected from the menu. 

Message controls 

The text of the message may be modified by the 
server, so only one message control is needed to 
display all the possible messages required. 

Initial text – The text of the message at start-up. 

Maximum length – The number of characters to 
allocate for storage including a zero terminator 
character. 

Icon – The icon to display along with the message.  
Depending on the client, this information may or 
may not be used. 

Response buttons – The response buttons to be 
displayed along with the message.  (Select None 
for 2.x compatibility.) 

Number controls 

All numbers are stored internally as integers.  Very 
large numbers and non-integer numbers are 
represented by shifting the decimal place as 
appropriate. 

Decimal format – Floating point will show as many 
decimal places as required to display the value.  
Fixed Point will show the number of decimal 
places specified by Decimal Places.  Exponent 
displays the same value in exponential format (i.e 

6104×  is represented as 4.000e06).  Shortest 
selects the shortest of these formats. 

Decimal places – Specifies how many digits are 
shown after the decimal point. 

Decimal shift – Specifies how to translate the 
internally stored integer into the value seen by the 
user.  If the integer value is 456, a multiplier of 0 
would represent it as 456, a multiplier of 2 would 
represent it as 45600, a multiplier of –2 would 
represent it as 4.56. 

Format string – Allows text to be placed before and 
after the numeric value.  %% in the format string 
will be replaced by the numeric value.  For 
example, if 5.67 was the value and d=%%cm was 
the format string, d=5.67cm would be displayed. 

Initial value – Value at power-up. 

Maximum limit / value – If selected, the client will 
not permit the user to enter a value greater than 
the value specified. 

Minimum limit / value – If selected, the client will 
not permit the user to enter a value less than the 
value specified. 

Modifiable – If selected, the value may be modified 
by the user. 

Password controls 

Passwords are limited to 16 characters (not 
including zero terminator.  Typically, mobile 
phones can only enter the digits 0-9 in a password 
control. 

Close on disconnect – If selected, automatically 
closes the password control when the client 
disconnects. 

Password – Initial password.  When the control is 
initially created, the password is “0000”. 

Master Password – If specified, provides a 
permanent, non-modifiable alternate password.  
Leave blank for no master password.  When the 
control is initially created, there is no master 
password. 

Modifiable – If selected, the password may be 
changed by the user. 

Section controls 

A section control’s child controls are hidden until 
the section is opened.  Child controls of a section 
control must be placed immediately after it in the 
control list and will be indicated by an indented 
entry in the ‘Type’ column of the control list.  

Close on disconnect – Closes the section 
automatically between one client disconnecting 
and another connecting. 

Initially open – Specifies that the section is open 
when the user interface first starts up. 

Sub-controls – The number of child controls in this 
section, including any sub-sections contained 
inside.   
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Text controls 

Initial text – The text that initially appears in the 
text control. 

Maximum length – The amount of storage required 
for the control, including a zero terminator 
character (i.e. number of characters in the line of 
text plus one).  If Unicode mode is used, this value 
refers to the number of characters rather than the 
number of bytes. 

Modifiable – If selected, the client may modify the 
text. 

Password – If the control is modifiable, selecting 
Password will obscure the entered text (e.g. as a 
series of bullets or asterisks).  Some remote 
devices can only enter the digits 0-9 in a 
password-style text control. 

Target Properties 

The Target Properties displayed will depend on the 
target selected. 

Simulation target 

COM port – Specifies the COM port used by 
Bluetooth to accept connections from other 
devices (the ‘Local Devices’ COM port). 

FlexiPanel BASIC Stamp Edition target 

Please note the FlexiPanel BASIC Stamp Edition 
the 10-pin SIL module.  The 28-pin DIL device is 
the Toothpick Stamp Edition. 

CTS pin – Specifies the Stamp I/O pin connected 
to the CTS pin on the module.  If the module is in 
the AppMod slot, this will be pin 6. 

Connect pin – Specifies that the Mode pin is an 
output indicating when a client device is connected. 

Data pin – Specifies the Stamp I/O pin connected 
to the Data pin on the module.  If the module is in 
the AppMod slot, this will be pin 12. 

RTS pin – Specifies the Stamp I/O pin connected 
to the RTS pin on the module.  If the module is in 
the AppMod slot, this will be pin 8. 

Rx pin – Specifies the Stamp I/O pin connected to 
the RxD pin on the module.  If the module is in the 
AppMod slot, this will be pin 4. 

Stamp Type – The type of BASIC Stamp 
connected to the module. 

Straight Thru mode – Specifies that the Mode pin 
is an input requesting Straight Thru mode.  Consult 
the module documentation for details. 

Tx pin – Specifies the Stamp I/O pin connected to 
the TxD pin on the module.  If the module is in the 
AppMod slot, this will be pin 2. 

Serial Adapter target 

Programming COM port – The Bluetooth COM port 
on the computer running Designer which will be 
used to connect to the DARC module to program it.  
This is the COM port used for making outgoing 
connections (the ‘Client Applications’) COM port.  
This is not necessarily the same COM port as 
specified for Simulations, which accepts incoming 
connections. 

Programming messages – Specifies whether 
message boxes should be shown if programming 
is successful.  If disabled, error messages will still 
be shown. 

Rewrite enable – Allows the DARC module to be 
re-programmed.  This is recommended during 
development.  When a product is released, rewrite 
should be disabled to prevent ‘hacking’.  If rewrite 
is disabled, only the factory reset pin (if enabled) 
may be used to re-program the module.  

Toothpick DARC-II target 

{pin} digital I/O function – Whether the pin is 
configured for digital input or output, or, in the case 
of CCP pins, PWM output.  Disabled if the pin is 
configured for analog I/O. 

AN2 analog I/O function – Whether the pin is 
configured for analog input or as a negative 
voltage reference for other analog inputs.  If not 
used as a voltage reference, the reference will be 
the power ground rail which may be noisy. 

AN3 analog I/O function – Whether the pin is 
configured for analog input or as a positive voltage 
reference for other analog inputs.  If not used as a 
voltage reference, the reference will be the power 
rail which may be noisy. 

Analog inputs – How many pins are configured for 
analog I/O. 

Input refresh rate – How frequently input values 
are polled. 
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On error – What to do if an error occurs. 

Parallel I/O x function – Specifies multiple digital 
pins shall comprise binary parallel input or output.  
Additionally, the pins must also be correctly 
configured as digital inputs or outputs. 

PWM period – Specifies the PWM period in PWM 
base time units. 

PWM base time units – Specifies the base time 
units of the PWM pulse generator.  Note that the 
PWM period is in base time units (range 1 to 256), 
the duty cycle is in quarter base time units (range 
0 to 1023). 

PIN Code – Specifies the Bluetooth authentication 
pin. 

Programming COM port – The Bluetooth COM port 
on the computer running Designer which will be 
used to connect to the DARC module to program it.  
This is the COM port used for making outgoing 
connections (a.k.a.  ‘Client Applications’) COM port.  
This is not necessarily the same COM port as 
specified for Simulations, which accepts incoming 
connections. 

Programming messages – Specifies whether 
message boxes should be shown if programming 
is successful.  If disabled, error messages will still 
be shown. 

Security Level – Specifies whether authentication 
and encryption are used. 

Toothpick Slave target 

Programming COM port – The Bluetooth COM port 
on the computer running Designer which will be 
used to connect to the DARC module to program it.  
This is the COM port used for making outgoing 
connections (the ‘Client Applications’) COM port.  
This is not necessarily the same COM port as 
specified for Simulations, which accepts incoming 
connections. 

Programming messages – Specifies whether 
message boxes should be shown if programming 
is successful.  If disabled, error messages will still 
be shown. 

Toothpick Stamp Edition target 

Please note the Toothpick Stamp Edition the 28-
pin DIL module.  The 10-pin SIL device is the 
FlexiPanel BASIC Stamp Edition. 

CTS pin – Specifies the CTS Stamp input pin 
connected to the RTS output pin on the Toothpick.  
The default is P11, allowing direct connection on 
the Board of Education, BS2p Demo Board and 
the Toothpick Industrial board. 

Data pin – Specifies the Stamp input pin 
connected to the Data output pin on the Toothpick.  
The default is P10, allowing direct connection on 
the Board of Education, BS2p Demo Board and 
the Toothpick Industrial board. 

Programming COM port – The Bluetooth COM port 
on the computer running Designer which will be 
used to connect to the Toothpick Stamp Edition 
module to program it.  This is the COM port used 
for making outgoing connections (a.k.a.  ‘Client 
Applications’) COM port.  This is not necessarily 
the same COM port as specified for Simulations, 
which accepts incoming connections. 

Programming messages – Specifies whether 
message boxes should be shown if programming 
is successful.  If disabled, error messages will still 
be shown. 

RTS pin – Specifies the Stamp RTS output pin 
connected to the CTS input pin on the Toothpick.  
The default is P9, allowing direct connection on the 
Board of Education, BS2p Demo Board and the 
Toothpick Industrial board. 

Reset pin – Specifies the Stamp I/O pin connected 
to the reset pin on the Toothpick (optional).  The 
default is P4, allowing direct connection on the 
Board of Education, BS2p Demo Board and the 
Toothpick Industrial board. 

Rx pin – Specifies the Stamp input pin connected 
to the TxD output pin on the Toothpick.  The 
default is P6, allowing direct connection on the 
Board of Education, BS2p Demo Board and the 
Toothpick Industrial board. 

Stamp Type – The type of BASIC Stamp 
connected to the module. 

Straight Thru mode – Specifies that the Mode pin 
is an input requesting Straight Thru mode.  Consult 
the module documentation for details. 

Tx pin – Specifies the Stamp output pin connected 
to the RxD input pin on the Toothpick.  The default 
is P2, allowing direct connection on the Board of 
Education, BS2p Demo Board and the Toothpick 
Industrial board. 
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Toothpick MPLAB target 

Programming messages – Specifies whether 
message boxes should be shown if programming 
is successful.  If disabled, error messages will still 
be shown. 

Pocket PC Properties 

The Pocket PC Properties controls the appearance 
of the user interface on Pocket PC devices.  The 
main screen displays the control layout.  The 
selected control is shown shaded. 

During development, remember to select Force 
Layout in the FlexiPanel Server Properties.   Any 
changes you make will then be immediately visible 
on the client without the need to select Load 
Recommended Layout. 

If a control’s position is unspecified, it appears on 
the upper portion of the screen.  To specify the 
position of a control, click on the ‘plus’ portion of 
the control and drag it to the desired position on 
the page in the lower portion of the screen.  You 
can also size the control by dragging on the 
double-arrow portion of the control. 

To aid layout, it is suggested you use the layout 
grid feature.  To hide a control, simply place it off-
screen (e.g. below the page pane). 

Section and Password controls can make other 
controls appear and disappear.  Therefore they 
have a ‘displayed state’ property which shows or 
hides the controls as appropriate.  They also have 
separate position and size properties for their open 
and closed states. 

Message controls are not shown. 

Axis limits – Specifies whether axis limits are 
specified.   

Displayed state – For section or password controls, 
specifies whether it is displayed in its open or 
closed state.  This may make other controls 
appear or disappear.  This property has no effect 
on the appearance on the actual client device, just 
on the screen layout. 

Font bold – Specifies whether the control text 
should be bold. 

Font size – Specifies the control font size, in points. 

Grid – Specifies the grid to which dragged controls 
will be anchored.  Enter 0 for no grid.  This is a 

global property which is applied to all controls 
when they are dragged. 

Height – Specifies the height of the control in 
pixels. 

Height (open) – Specifies the height of a section or 
password control in its open state. 

Hide on this client – Specifies that the control 
should not be displayed on Pocket PC.  (It will still 
be displayed in the FlexiPanel Designer Pocket PC 
Properties view.) 

Horizontal align – Specifies the alignment of an 
image control 

Justify – Specifies the justification of a text control 

Left – Specifies the left edge position of the control 
in pixels, relative to the left screen edge. 

Left (open) – Specifies the left position of a section 
or password control in its open state. 

Grid – Specifies the grid to which dragged controls 
will be anchored.  Enter 0 for no grid.  This is a 
global property which is applied to all controls 
when they are dragged. 

Page – Specifies the page on which a control 
appears.  Enter -1 to make it appear on all pages. 

Page (open) – Specifies the page for a section or 
password control in its open state. 

Ping frequency – Specifies that the client should 
ping the server every few seconds as specified.  
Enter 0 for no pings.  This is a global property 
which is applied to the whole user interface, not 
just the selected control. 

Request layout – Specifies whether Pocket PC 
layout features are requested for this control.  If 
this property is switched from the Yes state to the 
No state, all control layout properties will be lost. 

Show border – Specifies whether a border is 
requested for this control.   

Show dialog – If multiple dialogs are defined, 
allows you to switch between them.   

Show title – Specifies whether the control title is 
requested for this control.   
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Style – Specifies how the control is displayed.  
Applies to Date-Time, Latch, List, Matrix, Number 
and Text controls. 

Title font bold – Specifies whether the title text 
should be bold. 

Title font size – Specifies the title font size, in 
points. 

Top – Specifies the height of the control in pixels. 

Top (open) – Specifies the height of a section or 
password control in its open state. 

User modify layout – Specifies that the user may 
override the server’s control layout preference.  
This is a global property which is applied to the 
whole user interface, not just the selected control. 

User modify pings – Specifies that the user may 
override the server’s ping settings.  This is a global 
property which is applied to the whole user 
interface, not just the selected control. 

Vertical align – Specifies the alignment of an 
image control 

Width – Specifies the width of the control in pixels. 

Width (open) – Specifies the width of a section or 
password control in its open state. 

X axis max – Specifies the maximum for the X axis.   

X axis min – Specifies the minimum for the X axis.   

Y axis max – Specifies the maximum for the Y axis.   

Y axis min – Specifies the minimum for the Y axis.   

Windows PC Properties 

The Windows PC Properties controls the 
appearance of the user interface on Windows PC 
devices.  The main screen displays the control 
layout.  The selected control is shown shaded. 

During development, remember to select Force 
Layout in the FlexiPanel Server Properties.   Any 
changes you make will then be immediately visible 
on the client without the need to select Load 
Recommended Layout. 

If a control’s position is unspecified, it appears on 
the upper portion of the screen.  To specify the 
position of a control on the ‘plus’ portion of the 
control and place it in the desired position on the 

page pane in the lower portion of the screen.  You 
can also size the control by dragging on the 
double-arrow portion of the control. 

To aid layout, it is suggested you use the layout 
grid feature.  To hide a control, simply place it off-
screen (e.g. below the page pane). 

Section and Password controls can make other 
controls appear and disappear.  Therefore they 
have a ‘displayed state’ property which shows or 
hides the controls as appropriate.  They also have 
separate position and size properties for their open 
and closed states. 

Message controls are not shown. 

Axis limits – Specifies whether axis limits are 
specified.   

Displayed state – Specifies whether a section or 
password control is displayed in its open or closed 
state.  This may make other controls appear or 
disappear.  This property has no effect on the 
appearance on the actual client device, just on the 
screen layout. 

Font bold – Specifies whether the control text 
should be bold. 

Font size – Specifies the control font size, in points. 

Grid – Specifies the grid to which dragged controls 
will be anchored.  Enter 0 for no grid.  This is a 
global property which is applied to all controls 
when they are dragged. 

Height – Specifies the height of the control in 
pixels. 

Height (open) – Specifies the height of a section or 
password control in its open state. 

Hide on this client – Specifies that the control 
should not be displayed on Windows clients.  (It 
will still be displayed in the FlexiPanel Designer 
Windows Properties view.) 

Horizontal align – Specifies the alignment of an 
image control 

Justify – Specifies the justification of a text control 

Left – Specifies the left edge position of the control 
in pixels, relative to the left screen edge. 

Left (open) – Specifies the left position of a section 
or password control in its open state. 
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Grid – Specifies the grid to which dragged controls 
will be anchored.  Enter 0 for no grid.  This is a 
global property which is applied to all controls 
when they are dragged. 

Page – Specifies the page on which a control 
appears.  Enter -1 to make it appear on all pages. 

Page (open) – Specifies the page for a section or 
password control in its open state. 

Ping frequency – Specifies that the client should 
ping the server every few seconds as specified.  
Enter 0 for no pings.  This is a global property 
which is applied to the whole user interface, not 
just the selected control. 

Request layout – Specifies whether Windows 
layout features are requested for this control.  If 
this property is switched from the Yes state to the 
No state, all control layout properties will be lost. 

Screen width – Specifies the width of the drawing 
area of the client application program.   

Screen height – Specifies the height of the 
drawing area of the client application program.   

Show border – Specifies whether a border is 
requested for this control.   

Show title – Specifies whether the control title is 
requested for this control.   

Title font bold – Specifies whether the title text 
should be bold. 

Style – Specifies how the control is displayed.  
Applies to Latch, List, Matrix, Number and Text 
controls. 

Title font size – Specifies the title font size, in 
points. 

Top – Specifies the height of the control in pixels. 

Top (open) – Specifies the height of a section or 
password control in its open state. 

User modify layout – Specifies that the user may 
override the server’s control layout preference.  
This is a global property which is applied to the 
whole user interface, not just the selected control. 

User modify pings – Specifies that the user may 
override the server’s ping settings.  This is a global 
property which is applied to the whole user 
interface, not just the selected control. 

User modify size – Specifies that the user may 
modify the client application screen size.  This is a 
global property which is applied to the whole user 
interface, not just the selected control. 

Vertical align – Specifies the alignment of an 
image control 

Width – Specifies the width of the control in pixels. 

Width (open) – Specifies the width of a section or 
password control in its open state. 

X axis max – Specifies the maximum for the X axis.   

X axis min – Specifies the minimum for the X axis.   

Y axis max – Specifies the maximum for the Y axis.   

Y axis min – Specifies the minimum for the Y axis.   

Smartphone Properties 

The Smartphone Properties display is similar to 
the Control Properties display except the 
description is replaced by a description of the 
Smartphone features.   

On the Smartphone, the controls will appear in a 
list in the same order as specified on the Control 
Properties. 

All controls 

Fast key – Specifies a keypad key as a fast way of 
accessing the control. 

Hide control – Specifies that the control should not 
appear in the control list on the Smartphone 
platform. 

Ping frequency – Specifies that the client should 
ping the server every few seconds as specified.  
Enter 0 for no pings.  This is a global property 
which is applied to the whole user interface, not 
just the selected control. 

Request layout – Specifies whether Smartphone 
properties are requested for this control.  If this 
property is switched from the Yes state to the No 
state, all control layout properties will be lost.  This 
item must be selected to enable many of the 
others. 

Title characters – Specifies the number of 
characters of the control title which are to be 
displayed in the control list on the Smartphone. 
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User modify layout – Specifies that the user may 
override the server’s control layout preference.  
This is a global property which is applied to the 
whole user interface, not just the selected control. 

User modify pings – Specifies that the user may 
override the server’s ping settings.  This is a global 
property which is applied to the whole user 
interface, not just the selected control. 

Value style – Specifies the characters to display 
between the control title and the control value in 
the control list. 

List controls 

Style – Specifies how the list may be modified.  
Spinning allows the user to click through list items 
without opening the control first.  Looping allows 
the spin to loop from last entry back to the first and 
vice versa.   

Message controls 

Message controls do not have any specific 
Smartphone properties   

Number controls 

Style – Specifies how the number may be modified.  
Spinning allows the user to increment / decrement 
the value without opening the control first.   

Matrix controls 

Axis limits – Specifies whether axis limits are 
specified.   

Style – Specifies how the matrix is displayed.   

X axis max – Specifies the maximum for the X axis.   

X axis min – Specifies the minimum for the X axis.   

Y axis max – Specifies the maximum for the Y axis.   

Y axis min – Specifies the minimum for the Y axis.   

Java Phone Properties 

The current release of FlexiPanel Client for Java 
phones does not have any client-specific 
properties. 

Target Devices 

The Target Devices menu allows the target device 
to be selected.  It also allows the user interface to 
be sent to that target device.  Items marked * 
appear only when the relevant target is selected. 

Simulation  – The target is the FlexiPanel Server 
simulator in FlexiPanel. 

Serial Adapter – The target is a FlexiPanel Serial 
Adapter (RS232 or TTL level) module. 

BASIC Stamp Edition  – The target is a FlexiPanel 
Basic Stamp Edition module. 

Toothpick DARC-II  – The target is a Toothpick 
module running DARC-II firmware. 

Toothpick Slave  – The target is a Toothpick 
module running Toothpick Slave firmware. 

Toothpick Stamp Edition  – The target is a 
Toothpick module running Toothpick Stamp 
Edition firmware. 

Toothpick MPLAB  – The target is a Toothpick 
programmed using the MPLAB development 
environment. 

*Simulate now  – The Designer application acts as 
a FlexiPanel Server itself to simulate the user 
interface.  See the section Simulating User 
Interfaces. 

*Program Serial Adapter…  – Programs a serial 
adapter connected via Bluetooth. 

*Create BASIC programming code…  – Creates 
the required BASIC programming code to program 
the FlexiPanel Basic Stamp Edition module via the 
BASIC Stamp. 

*Program DARC-II…  – Programs the DARC-II by 
wireless field programming. 

*Program Toothpick Slave…  – Programs the 
Toothpick Slave by wireless field programming. 

*Program Toothpick Stamp Edition…  – 
Programs the Toothpick Stamp by wireless field 
programming.  Also creates a BASIC file of sample 
code for the BASIC Stamp. 

*Create C Code…  – Creates C code for importing 
into MPLAB.  Also creates a .hex file for wireless 
field programming of external memory data. 
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Simulating User Interfaces 
Once a user interface has been designed it may 
be simulated on a Bluetooth equipped Windows 
computer. 

To set up simulations on a particular Windows 
computer, set the Target Device to be Simulation.  
The Simulation Properties will appear in the right-
hand properties list  Select the correct Bluetooth 
COM port for incoming connections in the box 
provided. 

To simulate a user interface, select Simulate 
Now… from the Target Device menu.  The 
Simulating FlexiPanel… dialog box appears 
(Figure 1).  If a FlexiPanel Client device now 
connects to the computer, the user interface will 
appear.   

Last Message – The last notification message sent 
by the FlexiPanel Server to the application. 

Client Data – The contents of the last Client Data 
message sent by the FlexiPanel Server to the 
application.  In certain situations such as pressing 
a radio button, several Client Data messages may 
be sent in quick succession; only the last will be 
shown. 

Dialog – Selects which dialog is displayed.  

Update Control Data – Sends updated data for all 
controls except button, files and matrix controls.  
The section and password controls will be updated 
with the same values.  All others will be changed 
slightly.  

Show Messages Boxes – Press to make all 
message box controls appear, if any. 

End Simulation – Press to end the simulation.   
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Targeting BASIC Stamp 
Edition 
Once a user interface has been designed it may 
be programmed into a FlexiPanel BASIC Stamp 
Edition module.  The module will then perform all 
the tasks of a FlexiPanel Server and will retain all 
control settings for the BASIC Stamp.   

The FlexiPanel BASIC Stamp Edition module is 
programmed as follows: 

1. FlexiPanel Designer creates BASIC Stamp 
source code to program the module.  See for 
example Figure 4.  Note the extra sample 
code provided at the end of the file.  It shows 
how the BASIC Stamp should read and write 
from the FlexiPanel module once the user 
interface has been programmed. 

2. The source code is downloaded to a BASIC 
Stamp using the BASIC Stamp Editor.  A 
FlexiPanel BASIC Stamp Edition should be 
connected to the BASIC Stamp. 

3. When the program runs, the BASIC Stamp 
writes the user interface specification into the 
module.  After a few seconds, the BASIC 
Stamp Editor will confirm the process is 
complete writing Acknowledge: ROM to the 
Debug Terminal (Figure 2).  If the message 
does not appear, programming failed.  (Try 
removing and reapplying the power.) 

4. The user interface will be retained by the 
FlexiPanel BASIC Stamp Edition module until 
it is re-programmed, even after power-off. 

5. The BASIC Stamp is programmed with the 
necessary code to interact with the user 
interface and perform its intended tasks. 

The documentation for the FlexiPanel BASIC 
Stamp contains the example AllControlsDemo that 
shows the process in detail and uses most controls 
available to the BASIC Stamp. 

The FlexiPanel Module has the following 
limitations: 

• Only BS2, BS2e, BS2sx and BS2p BASIC 
Stamps are supported. 

• Files Control is not supported. 

• Real Time Clock is not supported. 

• Ping functionality must be enabled. 

• User Interface ROM space is limited to 
around 1780 bytes.  This limitation is 
actually a limitation of the BASIC Stamp 
used to program the FlexiPanel module.  It 
is sufficient for approximately 24 controls.  
This is also about the limit of what the 
BASIC Stamp can practically use during 
normal operation while retaining sufficient 
spare programming space to achieve a 
useful task. 

To prepare for programming FlexiPanel BASIC 
Stamp Edition modules, select BASIC Stamp 
Edition from the Target Device menu. The BASIC 
Stamp Properties will appear in the right-hand 
properties list. Set the BASIC Stamp type and 
select what you would like the Mode pin to do.  
Also specify which module pins are connected to 
which Stamp I/O pins.  If you are using the 
AppMod slot, you can keep the default values. 

To create BASIC Stamp source code to program 
the module (i.e. step 1 above) select Create 
BASIC programming code… from the Target 
Device menu.  The Storage Summary dialog box 
appears (Figure 3), followed by a dialog box 
prompting for a file name for the source code file to 
be created.  Select a file name and press OK.  A 
file will be created which may then be read into the 
BASIC Stamp Editor (i.e. step 2 above). 

Refer to the BASIC Stamp Edition documentation 
for further information and examples. 
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Targeting Serial Adapters  
Once a user interface has been designed it may 
be programmed into a Serial Adapter.  
Programming takes place via the Bluetooth link 
and therefore requires Designer to run on a 
computer which has a Bluetooth radio.   

The FlexiPanel Serial Adapter modules are 
programmed as follows: 

1. Select Program Serial adapter from the Target 
Device menu. 

2. The Storage Summary dialog box appears 
(Figure 3). 

3. If necessary, manually create an outgoing 
serial connection to the module using the 
computer’s Bluetooth Manager.  Whether this 
step is necessary or not depends on the 
Bluetooth driver.   

4. Press OK to program the Serial module.  For a 
full 8192-byte program, this may take ten 
seconds or so.  If programming was 
successful, a Programming succeeded 
message will be generated.  If programming 
fails, Designer will time-out after about 20 
seconds and generate an error message. 

Refer to the Serial module documentation for 
further information and examples. 
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Targeting Toothpick DARC-II  
Once a user interface has been designed it may 
be programmed into a DARC-II.  Programming 
takes place via the Bluetooth link and therefore 
requires Designer to run on a computer which has 
a Bluetooth radio.   

DARC-II modules are programmed as follows: 

1. Select Program DARC-II from the Target 
Device menu. 

2. The Storage Summary dialog box appears 
(Figure 3). 

3. Power up the DARC-II module with the button 
held down so that the LEDs flash 
simultaneously 

4. If necessary, manually create an outgoing 
serial connection to the DARC-II using the 
computer’s Bluetooth Manager.  Whether this 
step is necessary or not depends on the 
Bluetooth driver.   

5. Press OK to program the DARC-II module.   

Refer to the DARC-II module documentation for 
further information and examples. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Page 25 29-Jan-07 Designer rev 2 © FlexiPanel Ltd Patents apply and/or pending  www.FlexiPanel.com 

Targeting Toothpick Slave  
Once a user interface has been designed it may 
be programmed into a Toothpick Slave.  
Programming takes place via the Bluetooth link 
and therefore requires Designer to run on a 
computer which has a Bluetooth radio.   

Toothpick Slave modules are programmed as 
follows: 

1. Select Program Toothpick Slave from the 
Target Device menu. 

2. The Storage Summary dialog box appears 
(Figure 3).  If your user interface uses a lot of 
RAM, check that the storage requirements do 
not interfere with the message stack size you 
will be using.  (See Toothpick Slave 
documentation.) 

3. Power up the Toothpick Slave module with the 
button held down so that the LEDs flash 
simultaneously 

4. If necessary, manually create an outgoing 
serial connection to the Toothpick Slave using 
the computer’s Bluetooth Manager.  Whether 
this step is necessary or not depends on the 
Bluetooth driver.   

5. Press OK to program the Toothpick Slave 
module.  The LEDs will flash alternately until 
programming is complete.   

Refer to the Toothpick documentation for further 
information and examples. 
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Targeting Toothpick Stamp 
Edition  
Once a user interface has been designed it may 
be programmed into a Toothpick Stamp Edition.  
Programming takes place via the Bluetooth link 
and therefore requires Designer to run on a 
computer which has a Bluetooth radio.   

Toothpick Stamp Edition modules are programmed 
as follows: 

1. Select Program Toothpick Stamp Edition from 
the Target Device menu. 

2. The Storage Summary dialog box appears 
(Figure 3).  If your user interface uses a lot of 
RAM, check that the storage requirements do 
not interfere with the message stack size you 
will be using.  (See Toothpick Stamp Edition 
documentation.) 

3. A Save As dialog box appears.  Save the 
BASIC file.  This file contains sample BASIC 
code for you to use when programming the 
Stamp.  Most importantly, it contains constants 
which may change as you insert, delete or 
move controls in the user interface control list.  
Each time you modify the controls, you should 
copy the new constants (between the ====== 
lines) into your BASIC code. 

4. Power up the Toothpick Stamp Edition module 
with the button held down so that the LEDs 
flash simultaneously 

5. If necessary, manually create an outgoing 
serial connection to the Toothpick Stamp 
Edition using the computer’s Bluetooth 
Manager.  Whether this step is necessary or 
not depends on the Bluetooth driver.   

6. Press OK to program the Toothpick Stamp 
Edition module.  The LEDs will flash 
alternately until programming is complete. 

Refer to the Toothpick Stamp Edition 
documentation for further information and 
examples. 
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Targeting Toothpick MPLAB  
Once a user interface has been designed it may 
be programmed into a DARC-II.  Programming 
takes place via the Bluetooth link and therefore 
requires Designer to run on a computer which has 
a Bluetooth radio.   

The Toothpick MPLAB modules are programmed 
by generating .c and .h files which are included 
in the MPLAB project.  In addition, a .hex file is 
created if external memory needs to be 
programmed with FlexiPanel User Interface 
information. 

1. Select Create C Code from the Target Device 
menu. 

2. The Storage Summary dialog box appears 
(Figure 3).  Press OK. 

3. Select a file name for the .c file. 

4. Select a file name for the .h file. 

5. Select a file name for the .hex file if required. 

Refer to the Toothpick documentation for further 
information and examples. 
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Figures 

 
 

Figure 1 – Dialog Shown During Simulation  

 

 

Figure 2 – Programming a FlexiPanel BASIC 
Stamp Edtion module  

 

 

Figure 3 – FlexiPanel Storage Summary 

 

 

 

 

(Figure 4 obsolete) 
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'------------------------------------------------------------------------------------------- 
' 
'  FxP FlexiPanel.bs2 
' 
'  BS2 code for programming FlexiPanel control panel 
' 
'  Created at 15:24:30 on 3/27/04 
' 
'------------------------------------------------------------------------------------------- 
 
'  Initialization 
 
'{$STAMP BS2} 
 
'------------------------------------------------------------------------------------------- 
 
'  Data 
 
ROMData DATA $01, $00, $00, $00, $00, $00, $46, $6C, $65, $78, $69, $50, $61, $6E, $65, $6C 
   {Many rows of data like this} 
        DATA $01, $91, $00, $00, $00, $00, $00, $00, $00, $00, $00, $00, $00, $00, $00, $00 
 
'------------------------------------------------------------------------------------------- 
 
' Variables 
 
cdata   VAR     BYTE 
ack     VAR     BYTE(3) 
i       VAR     WORD 
 
 
'------------------------------------------------------------------------------------------- 
 
' Start of code 
 
' Initialize Serial Port 
 
        DIR2  = 1    ' Tx to FxP (SEROUT output from Stamp) 
        OUT2  = 1    ' Initialize Tx as high 
        DIR6  = 0    ' CTS from FxP  (SEROUT flow control input to Stamp) 
        DIR4  = 0    ' Rx from FxP (SERIN input to Stamp) 
        DIR8  = 1    ' RTS to FxP   (SERIN flow control output from Stamp) 
        OUT8  = 1    ' Initialize RTS as high 
        DIR12 = 0    ' Data from FxP (SERIN input to Stamp) 
 
'  Wait 50 ms for FxP to initialize; if you use pullup resistors on CTS/Rx this is not needed 
 
        pause 50 
 
'  Program ROM 
 
        debug "Programming ROM...", CR 
        serout 2\6, 32, [$81, $06] 
        for i = 0 to $5F 
            read ROMData+i, cdata 
            serout 2\6, 32, [cdata] 
        next 
        debug "Awaiting acknowledge...", CR 
        serin  4\8, 32, [STR ack\3] 
        debug "Acknowledge: ", STR ack\3, CR 
 
 
'  Finished 
 
        stop 
 
 

 

Figure 4 – FlexiPanel BASIC Stamp Edtion programming script.  (Continues…)  
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'------------------------------------------------------------------------------------------- 
 
'  The following constants will be useful: 
 
        TxPin   con     2       ' Transmit pin (from stamp) 
        RxPin   con     4       ' Receive pin (to Stamp) 
        CTSPin  con     6       ' Transmit flow control pin (input to Stamp) 
        RTSPin  con     8       ' Receive flow control pin (output from Stamp) 
        DataPin var     IN12    ' Data ready pin (input to Stamp) 
        BaudM   con     32      ' Baud mode 
 
        GetData con     $01      ' Get control data command 
        SetData con     $02      ' Set control data command 
        SetRow  con     $06      ' Set a row of matrix data command 
        AddRow  con     $07      ' Append a row of matrix data command 
        GetMod  con     $03      ' Get modified control command 
        ShowMsg con     $04      ' Show message command 
        ID_Text1 con $01      ' Text1 control ID 
 
'------------------------------------------------------------------------------------------- 
 
'  Use the following sample code to set up the Stamp I/O 
' 
'       DIR2  = 1    ' Tx to FleixPanel (SEROUT output from Stamp) 
'       OUT2  = 1    ' Initialize Tx as high 
'       DIR6  = 0    ' CTS from FleixPanel  (SEROUT flow control input to Stamp) 
'       DIR4  = 0    ' Rx from FleixPanel (SERIN input to Stamp) 
'       DIR8  = 1    ' RTS to FleixPanel   (SERIN flow control output from Stamp) 
'       OUT8  = 1    ' Initialize RTS as high 
'       DIR12  = 0    ' Data from FleixPanel (SERIN input to Stamp) 
 
'------------------------------------------------------------------------------------------- 
 
'  Use the following sample code to read the text of the 'Text1' text control: 
' 
'       text  VAR     BYTE(10) 
' 
'       serout TxPin\CTSPin, BaudM, [GetData, ID_Text1] 
'       serin  RxPin\RTSPin, BaudM, [STR text\10] 
 
 
'  Use the following sample code to set the text of the 'Text1' text control: 
' 
'       serout TxPin\CTSPin, BaudM, [SetData, ID_Text1, STR text\10] 
 
'  All strings must be zero terminated!  
'  Note that all 10 bytes must be read or written each time, even if you don't need them all  
 
 
'------------------------------------------------------------------------------------------- 
 
 
'  Use the following sample code to see if any controls have been modifed by client  
'  substituting for [] as appropriate  
'  (returns $00 if no controls have been modified, otherwise the ID of a modified control): 
' 
'       modctl   VAR     BYTE 
' 
'       serout TxPin\CTSPin, BaudM, [GetMod] 
'       serin  RxPin\RTSPin, BaudM, [modctl] 
 
 
'------------------------------------------------------------------------------------------- 
 
 

Figure 4 – FlexiPanel BASIC Stamp Edtion programming script.  (Continued)  

Note the commented out sample code automatically provided for the user interface. 
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FlexiPanel Designer Development Kit  
The FlexiPanel Designer development kit is comprised of the following files: 

• The Designer.exe application. 

• This documentation, Designer.pdf. 
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Revision History 
The table below details the revisions that have been made to FlexiPanel Designer from version 2.0. 

Version Date Detail 
23 Mar 2004 Initial release 

Client profiles added to simulation 26 Apr 2004 
Smartphone client profiles added 

28 Apr 2004 AckData function added to Stamp target 
28 Apr 2004 RAM storage error if more than 0x100 bytes allocated – corrected 

2.0 

28 Apr 2004 Spurious debug message if ROM storage used – removed 
07 Jul 2004 Properties list area added, client layout screens added. 
09 Jul 2004 Properties list general properties not updating when user makes 

changes – corrected. 
10 Jul 2004 DARC module / Stars ‘n’ Stripes module programming added  
11 Jul 2004 Copied controls can’t be laid out in PPC / Win - corrected. 
18 Jul 2004 Matrix XY and Labels styles showing each other’s properties – corrected 
04 Aug 2004 Properties list resizing wrongly after main window sized – corrected 
16 Aug 2004 Frequency input on DARCpins D0-D3 added. 

Default Ping interval increased to 5 seconds. 14 Sep 04 
Stamp pin values sticking on 15 when modified – corrected 
Checksum infrastructure added  
Unique name on startup and New 
Force Layout on by default 

15 Sep 04 

Update Control Data feature added to simulation 
18 Sep 04 AddRow memory error for XY chart if more than one column - corrected 
25 Oct 04 Crashing on double-click in drag & drop mode – corrected 

2.3 

16 Dec 04 Improved drag & drop mode – selected control on top 
3.0.00001 18 Dec 04 Image control added; matrix control can generate response; more 

number control options; matrix row update messages; matrix controls 
rendered inline. 

3.0.00004 13 Apr 05 Toothpick Slave, Toothpick DARC-II, Toothpick MPLAB targets 
supported. 
Toothpick Stamp Edition target supported. 19 Jun 05 
Bona fides added to wireless field programming 

3.0.00005 

12 Nov 05 List control SetUp macro error corrected 
4.0.0 12 Jan 07 ToothPIC name change to Toothpick 
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Contact Details 
 
 
Technical Information  

FlexiPanel Designer is owned and developed by FlexiPanel Ltd.   

 

FlexiPanel Ltd 
2 Marshall St, 3rd Floor 
London W1F 9BB, United Kingdom 
www.flexipanel.com 
email: support@flexipanel.com 

 

 

 

 


